CVE Feed
7.5 High

Multer is a node.js middleware for handling multipart/form-data.

CVE-2025-47944

Impact A vulnerability in Multer versions >=1.4.4-lts.1 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Patches Users should upgrade to 2.0.0 Workarounds None References https://github.com/expressjs/multer/issues/1176 https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665

Assessment

CVSS
7.5 (v3.1)
Severity
High
EPSS
0.81% chance of exploitation in the next 30 days
Known exploited
Not listed in CISA KEV
Exploit availability
Nothing found in Exploit-DB, Metasploit, Nuclei or public PoC repositories
Published
19 May 2025
Last updated
17 June 2026
Affected
expressjs · multer · multer
Weakness
CWE-248
Assigner
security-advisories@github.com

CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

At the source

References

Community proofs of concept

No community proof of concept yet. If you have one for a published vulnerability and the right to share it, add it below — it will appear here once reviewed.

Submit a proof of concept
Before you submit *

Query this programmatically

Agents can read this through the MCP endpoint, or over HTTP:

curl https://cve.zerocrew.in/api/cve/CVE-2025-47944