CVE Feed
7.5 High

Multer is a node.js middleware for handling multipart/form-data.

CVE-2025-7338

Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.

Proof-of-concept code is published

Public PoC

Signals come from Exploit-DB, Metasploit, Nuclei and published proof-of-concept repositories. Their absence means nothing was found, not that nothing exists.

Assessment

CVSS
7.5 (v3.1)
Severity
High
EPSS
0.81% chance of exploitation in the next 30 days
Known exploited
Not listed in CISA KEV
Exploit availability
Public PoC
Published
17 July 2025
Last updated
17 June 2026
Affected
expressjs · multer · multer
Weakness
CWE-248
Assigner
ce714d77-add3-4f53-aff5-83d477b104bb

CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

At the source

References

Community proofs of concept

No community proof of concept yet. If you have one for a published vulnerability and the right to share it, add it below — it will appear here once reviewed.

Submit a proof of concept
Before you submit *

Query this programmatically

Agents can read this through the MCP endpoint, or over HTTP:

curl https://cve.zerocrew.in/api/cve/CVE-2025-7338