CVE Feed
8.1 High

CKEditor: Cross-site scripting (XSS) in the engine package

CVE-2026-116688

Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the es-toolkit library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming style attribute values. The underlying issue has been patched by the library maintainers, and the fix has been incorporated into CKEditor 5. Patches The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS). For more information Email us at [security@cksource.com](mailto:security@cksource.com) if you have any questions or comments about this advisory.

Assessment

CVSS
8.1 (v3.1)
Severity
High
EPSS
0.00497% chance of exploitation in the next 30 days
Known exploited
Not listed in CISA KEV
Exploit availability
Nothing found in Exploit-DB, Metasploit, Nuclei or public PoC repositories
Published
27 October 2026
Last updated
27 October 2026
Affected
npm · ckeditor5, @ckeditor/ckeditor5-engine
Weakness
CWE-79

CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

At the source

References

Community proofs of concept

No community proof of concept yet. If you have one for a published vulnerability and the right to share it, add it below — it will appear here once reviewed.

Submit a proof of concept
Before you submit *

Query this programmatically

Agents can read this through the MCP endpoint, or over HTTP:

curl https://cve.zerocrew.in/api/cve/CVE-2026-116688